Depuración de una aplicación nativa reaccionar/expo con WebStorm

Pregunta hecha: hace 9 meses Ultima actividad: hace 8 meses
up 2 down

No puedo depurar mi reaccionan aplicación nativa/Expo en WebStorm, pero no puedo en código de Visual Studio. Tengo una aplicación nativa que pueda ejecutar con éxito utilizando Expo reaccionar. He definido la configuración de acuerdo con la información en este sitio:

https://blog.jetbrains.com/webstorm/2018/02/webstorm-2018-1-eap-181-3263/#debugging-expo

Cuando hago clic en "Ejecutar" o "depuración" y "depuración remota JS" está desactivado, el bundler construye un paquete JS y la aplicación se inicia en mis dispositivos. Pero una vez que enciendo "depuración remota JS", la única bundler dice:

A partir depurador personalizada mediante la ejecución:: [mi directorio de trabajo] [mi directorio de trabajo de nuevo]

y nunca va a construir el paquete de JS. Después de un corto periodo de tiempo, aparece una pantalla roja en el dispositivo, y que dice:

No se puede conectar con el depurador remoto

Tiempo de espera mientras se conecta al depurador remoto

onFailure   DevSupportManagerImpl.java:851

onFailure   WebsocketJavaScriptExecutor.java:83

correr   WebsocketJavaScriptExecutor.java:142

handleCallback   Handler.java:790

dispatchMessage   Handler.java:99

...

El bundler no dice nada más que el mensaje anterior. Tan pronto como apago la depuración remota, la construcción de la bundler comienza de nuevo y termina con

"Paquete de construcción de JavaScript: terminado en... ms"

como de costumbre, pero el dispositivo, una vez más, muestra la pantalla roja con los mensajes antes mencionados, o no muestra nada, pero la pantalla blanca regular con un mensaje en la parte inferior que dice "Downlading JavaScript bundle 100,00%". I o bien tienen que parar y reiniciar dentro WebStorm o tengo que cerrar la aplicación exposición y volver a abrirlo. De cualquier manera hará que la aplicación se inicia de nuevo en mi dispositivo.

Esta es la primera vez que trabaja con javascript, reaccionar nativa, expo, así que no estoy seguro, pero debe ser posible depurar en WebStorm directamente, ¿verdad? Como se ha mencionado, en Visual Studio Código de todo, incluyendo la depuración funciona bien, así que no creo que sea nada en el código. Tal vez alguien aquí tiene una idea dónde está el problema?

nodo -v: v11.6.0 reaccionar nativo -v: reaccionar nativo-cli: 2.0.1, reaccionar nativo: 0.57.1

¡Cualquier ayuda será apreciada! ¡Gracias por adelantado!

1 respuesta

up 1 down accepted

El problema se hace un seguimiento a WEB-35719, Siga por cambios